Skribble regular maintenance
Scheduled for 17.09.2024 at 18:00 – 19:30
Completed
17.09.2024 at 19:30Completed
17.09.2024 at 19:30Maintenance has completed successfully
In progress
17.09.2024 at 18:00In progress
17.09.2024 at 18:00Maintenance is now in progress
Planned
17.09.2024 at 18:00Planned
17.09.2024 at 18:00Regular maintenance/update of Skribble platform and infrastructure.