Skribble AG - Signatures with AES4Business / GlobalSign - Connectivity issues – Incident details

All systems operational

Signatures with AES4Business / GlobalSign - Connectivity issues

Resolved
Operational
Started 9 days agoLasted about 2 hours

Affected

External (Third Party) Services

Major outage from 11:04 AM to 12:39 PM

GlobalSign Atlas

Major outage from 11:04 AM to 12:39 PM

Updates
  • Resolved
    Resolved

    Incident Summary:

    On November 12th 2024, an upgrade to the latest version of GlobalSign Atlas inadvertently disabled the mTLS certificate expiration warning. As a result, no notification was received on either the GlobalSign or Skribble side regarding the certificate status. This led to a temporary disruption in the secure communication channel, impacting functionality for signatures and the AES4Business feature.

    Timeline of Events:

    1. Issue Detected: 12:00 - Discovered interruption in the secure channel between GlobalSign and Skribble, affecting specific features.

    2. Root Cause Analysis: 12:15 - Identified that the mTLS certificate expiration warning had been disabled in the updated GlobalSign Atlas version, preventing any proactive alerts.

    3. Resolution: 13:40 - Updated the secure channel between GlobalSign and Skribble, restoring all functionalities, including AES4Business.

    Resolution:

    The secure communication channel between GlobalSign and Skribble was reestablished. Signature services and the AES4Business feature are now functioning as expected.

    Follow-Up Actions:

    1. Review and Update Communication Channels: All communication channels between Skribble and GlobalSign will be reviewed and updated to ensure uninterrupted notifications and functionality.

    2. Long-Term Validity Assurance: The renewed connection is valid for the next five years, minimizing the risk of similar issues during this period.

    Conclusion:

    The issue has been resolved, and measures are in place to prevent recurrence. We expect smooth operations and reliable notifications over the next five years due to the updated connection configuration.

  • Investigating
    Investigating

    We are currently investigating this incident with our AES4Business features and connectivity with GlobalSign.