Skribble AG - Identification Service Interruption – Incident details

All systems operational

Identification Service Interruption

Resolved
Operational
Started about 1 month agoLasted about 3 hours

Affected

Internal Services

Operational from 3:05 PM to 5:40 PM

Skribble Platform

Operational from 3:05 PM to 5:40 PM

Updates
  • Resolved
    Resolved

    The identification process is now functioning properly. Thank you for your patience. If you need help, please contact support.

  • Investigating
    Investigating

    We're currently observing inconsistent behavior with our identification process that might impact some users. For immediate needs, please utilize the self-paid option via https://srsident.trustservices.swisscom.com or submit a support ticket for assistance. Rest assured, we're on the case and will have things back to normal soon. Your patience is greatly appreciated.