Skribble AG - Login not working – Incident details

All systems operational

Login not working

Resolved
Operational
Started 4 months agoLasted about 2 hours

Affected

Internal Services

Major outage from 3:45 PM to 5:52 PM, Operational from 3:45 PM to 6:00 PM

Skribble API

Operational from 3:45 PM to 6:00 PM

Skribble Platform

Major outage from 3:45 PM to 5:52 PM, Operational from 5:52 PM to 6:00 PM

Updates
  • Update
    Update

    Incident Summary:

    On November 11th 2024, 16:45, a maintenance script inadvertently removed access rights for a system user required during a post-authentication process. While the primary login function remained operational, a secondary process that logs user data from our Identity Provider (IDP) service failed due to insufficient permissions. This led to presumed login failures on our website from the user perspective.

    Timeline of Events:

    1. Issue Detected: 16:45 - Users reported presumed login failures.

    2. Root Cause Analysis: 17:45 - Identified that a maintenance script had removed access rights for a specific system user involved in the post-authentication data logging process.

    3. Resolution: 18:30 - Restored the system user’s permissions, allowing the post-authentication process to function as intended.

    Resolution:

    The system user’s permissions were restored, returning the post-authentication process and website functionality to normal.

    Follow-Up Actions:

    1. Maintenance Task Correction: Updated the maintenance script to prevent unintentional permission removals for essential system users in the future.

    2. Verification: Reviewed other critical processes to ensure no additional permissions were affected.

    Conclusion:

    The issue was successfully resolved, and preventive measures have been implemented to mitigate the risk of similar incidents. The system is now performing as expected, and no further interruptions are anticipated.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating
    We are currently investigating this incident.