Skribble regular maintenance
Scheduled for 11.06.2024 at 18:00 – 19:00
Completed
11.06.2024 at 19:00Completed
11.06.2024 at 19:00Maintenance has completed successfully
In progress
11.06.2024 at 18:00In progress
11.06.2024 at 18:00Maintenance is now in progress
Planned
11.06.2024 at 18:00Planned
11.06.2024 at 18:00Regular maintenance/update of Skribble platform and infrastructure.