Planned Maintenance: Subscription Management & Billing System Migration
Scheduled for 15.01.2026 at 17:30 – 16.01.2026 at 07:29
Affects
Internal Services
Under maintenance from 5:30 PM to 7:29 AM
Skribble Platform
Under maintenance from 5:30 PM to 7:29 AM
Completed
16.01.2026 at 07:29Completed
16.01.2026 at 07:29Maintenance has completed successfully.
In progress
15.01.2026 at 17:30In progress
15.01.2026 at 17:30Maintenance is now in progress
Planned
15.01.2026 at 17:30Planned
15.01.2026 at 17:30Scheduled: Thursday evening – Friday (full day)
Impact: Limited subscription management for existing customers
We are performing a planned migration of our subscription and billing system to improve reliability and simplify future operations.
What’s happening
Customer impact
During an 8–10 hour window on Friday, existing customers will temporarily be unable to modify their subscriptions, including:
New signups are not expected to be affected.
What to expect
No data loss is expected.
A small number of customers may experience delays or require manual follow-up after the migration.
Our engineering and support teams will be actively monitoring the process throughout Friday.
Thank you for your patience and understanding.